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How to retrieve your data

Cóm recuperar les teves dades (en Català) | Other languages using Google Translate

Your data acquired on any of the NMR Service spectrometers are available at all times and from
anywhere through our data server. To retrieve them, you will have to download and install the
program FileZilla, and configure it to connect to our server securely.

In order to preserve the privacy of the groups' research data, each research group and company has
a virtual account for its exclusive use, that allows it to access only its data folders on the SeRMN
spectrometers and computers.

The data server uses ProFTPD to manage the secure connection and transfer of data using the ]
protocol FTPS/FTPES. This data transfer protocol uses  TLS to encrypt communications between the
client and the server. This is the same encryption protocol that browsers use to access secure web
servers via HTTPS.

To access the data server you will need a  FTP client that allows TLS encrypted connections. We
recommend the program FileZilla although you can use others that support the FTPS/FTPES (FTP over
TLS) protocol.

The folders on the data server

When you log in, you will see several folders that link directly to data folders on currently available
spectrometers as well as former spectrometers. The name of the folder indicates which spectrometer
it corresponds to.

Current spectrometers

These folders correspond to the spectrometers currently installed in the service:

Folder name Current spectrometers
av-dpx-250-auto Spectrometer Avance DPX 250 MHz, with sample changer.
av-neo-300 Spectrometer Avance Neo 300 MHz for self-service.
av3-400-sb Spectrometer AvanceIII 400 MHz, with an HR-MAS accessory.
av-neo-400 Spectrometer Avance Neo 400 MHz for self-service.
av-neo-500 Spectrometer Avance Neo 500 MHz, with cryoprobe.
av3-600 Spectrometer AvanceII+ 600 MHz, with sample changer.
biospec-7T Spectrometer BioSpec 70/30USR with an horizontal magnet.

Former spectrometers

These folders correspond to spectrometers previously installed in our facility that no longer exist:
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Folder name Former spectrometers
av-dpx-250-robot Spectrometer Avance DPX-250 MHz, with sample changer.
av-dpx-360 Spectrometer Avance DPX-360 MHz for self-service.
av2-400-wb Spectrometer AvanceII 400 MHz, wide-bore magnet, with CP/MAS accessory.
av-drx-500 Spectrometer Avance DRX-500 MHz, with cryoprobe and LC-DAD-(SPE)-NMR/MS.

You will probably never see all of these instruments, as each group only sees the spectrometers that
at least one member of the group has access to.

Each research group and company only has access to their data folders.

Thus, when acquiring spectra make sure you save the data in your group folder. If
you save it in the wrong folder, you will not be able to retrieve it through the data server.

Use only unaccented letters, numbers, and dashes (uppercase and lowercase)
for experiment names,

It is highly recommended that you only use:

lowercase and uppercase letters without accents: a-z A-Z
numbers: 0-9
hyphens: - _

for experiment names, because other characters (accents, asterisk, quotes, parentheses,
etc.) could cause problems when retrieving your data.

Open the firewall of your institute or company

The FTPS/FTPES client and server communicate via ports 990 (FTPS) and 60000-65534 (IANA
Ephemeral ports), thus you will have to make sure they are not blocked by any firewalls.

In mid-2022 we changed the FTPS server port number from 21 to 990 in order to
use the official port number for this protocol:

Port 990 Details
Service: ftps
Details: FTPS Protocol, FTP over TLS/SSL (IANA official) uses ports 989 and 990.
https://www.speedguide.net/port.php?port=990

If you access our server from within the UAB, or from a research institute or company on campus that
has its network integrated into the UAB network, you should have no problems connecting and

https://www.speedguide.net/port.php?port=990
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downloading your data.

Conversely, if you connect from an off-campus computer, and your institute or company has a firewall
to protect its network, you will have to ask the people responsible for the firewall to configure it so
that you can retrieve your data .

The configuration is very simple and does not entail an unacceptable security risk, the steps required
are :

open outbound port 990 (FTPS) for the TCP protocol; and
open inbound the range of ports 60000-65534 (IANA Ephemeral ports for FTPS) for the TCP
protocol to computers on your network

so that you can connect to our FTPS-TLS server via FTPS-Passive from inside the firewall.

If they want to further restrict open ports only to our IP address, tell them it's IP: 158.109.58.175
with hostname: sermn.uab.cat

Don't worry if you don't understand this technical information, it is meant for your firewall
administrators.

Access your data with FileZilla

 The program we recommend to access
our data server is FileZilla, an FTP client
with a graphical interface, available for
Windows, Mac OS X and Linux.

At the time of writing these instructions, the most current version is 3.66.4, but since new versions
come out quite often, you will probably find a newer version to download and install. On the other
hand, it is highly recommended that you pay attention to the program when it informs you that there
is a new version and suggests that you download and install it. Doing so is only takes a moment, and
requires no software reconfiguration.

Installation

On the website of the FileZilla program you will find complete, detailed and up-to-date installation

http://filezilla-project.org/
https://sermn.uab.cat/wiki/lib/exe/detail.php?id=howto_retrieve_your_data&media=informacio_usuaris:f01.png
http://wiki.filezilla-project.org/Client_Installation
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instructions on how to install FileZilla Client on MS-Windows, Mac OS X, and GNU/Linux.

You can download the program directly from the FileZilla website.

Detailed configuration

If you are not familiar with FileZilla configuration follow these detailed instructions. There we explain
step by step how to configure the program to access our data server, in addition, the multiple
screenshots will help you to successfully complete the configuration process.

Otherwise, use the quick setup instructions in the next section.

Quick setup

If you are familiar with FileZilla use these short instructions to set it up:

Go to Edit → Settings1.
In Transfers → File Types set the configuration to,1.

Default transfer type: Binary
Uncheck the options Treat files without extension… i Treat dotfiles as…

In Language2.
Choose the interface language

Press Ok  to save the changes and to exit the Settings window.3.
Go to File → Site Manager2.

Press New Site  to create a new site. Call it something like SeRMN-UAB Data Server.1.
In the General tab enter the following values:2.

Host: sermn.uab.cat
Port: 990
Protocol: FTP - File Transfer Protocol
Encryption: Require explicit FTP over TLS

Define the account type and access credentials,3.
If this is a computer for exclusive use by members of the research group, set it up
with:

Logon Type: Normal
User: type the username of your group (ask your Group Leader or a
senior member)
Password: optionally type the password of your group (ask your
Group Leader or a senior member for it)

If this is a computer shared with other groups or individuals, set
Logon Type: Interactive, and
let FileZilla to prompt you for the user name and password everytime that
someone wants to log in.

Press Ok  to save the configuration and to exit the Site Manager window.4.

Now you can try to connect to our data server:

Select the site SeRMN-UAB Data Server (or the name you have entered) at File → Site Manager1.
If you have configured your account as Logon Type: Normal the program will only ask for1.
your group's password if you did not save it.

http://wiki.filezilla-project.org/Client_Installation
http://filezilla-project.org/download.php
https://sermn.uab.cat/wiki/doku.php?id=configuracio_filezilla
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If you have configured your account as Interactive the program will only ask for your2.
group's username and password.

In both cases press the Ok  button to start the connection.2.
If you have not yet accepted our server certificate, or if we have renewed it, the program will3.
show you the certificate data and ask you if you accept it. Press the Ok  button to accept the
certificate and continue with the connection.
If everything went well, you should now see the list of instruments that your research group has4.
access to.

You must ask the head of your research group or company for access
credentials.

The SeRMN only provides the access credentials (*username* and *password*) to those
responsible at each research group or company, and the distribution of this information
within the research group or company is their responsibility.

Remember that each research group only has access to its data folders. When you
acquire spectra, make sure you save the data in your group folder. Otherwise you
won't be able to retrieve it over the network.

If you have any problems retrieving your data through the server, please contact the
service staff and we will try to resolve the issue.

Example of data transfer session

The following images show how to download data from the data server. The first thing you will have to
do is open the Site Manager, select the account where you have defined the connection to our data
server, and press the Connect  button to start a session,
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If you have configured the connection parameters correctly, and if there are no problems with the
network, a screen will immediately open with the digital certificate that identifies our data server. To
continue you must accept it by pressing the OK  button.

The data server uses an official UAB certificate generated by GEANT Vereniging that is
renewed annually.
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If you don't want to have to accept the certificate every time you connect, check the
option Always trust certificate in future sessions.

If the login username and password are already defined in the account (see above, Logon type set to
Normal) the FTP client will proceed directly to start a session. On the other hand, if you have defined
an interactive type account (see above, Logon type set to Interactive), the program will first ask for
your username and then your password before starting a session,

In both cases the program will show you the commands it executes and the contents of the remote
folder on the data server,
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The figure above shows the FileZilla screen with default graphics settings,

In panel 1 you can see the messages exchanged between the client and the server. In the
event of problems, this information can help us to identify the cause of the problem and to
resolve it.
Panel 2 displays the local directory tree, and panel 3 shows the listing of folders and files
contained in the currently open local folder.
Similarly, panel 4 shows the directory tree on the remote data server, and panel 5 shows the
list of folders and files contained in the currently open remote server folder.
Finally, depending on the selected tab, in panel 6 you can check the status of the file transfer:
files in queue, files transferred, and errors in the file transfer.

The configuration of the graphical interface can be modified through the View menu.

To transfer data you must first choose the spectrometer or computer you want to access,

inside each spectrometer folder you will find at least one folder named nmr containing the most
current data, although there may also be other folders corresponding to previous years.

To transfer the data of an experiment you must select the corresponding folder

and, with the right mouse button, expand the menu and choose the option Download
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After the file transfer is complete, the data folders will appear in the panel corresponding to the local
folder on your computer.

Alternatively, you can drag the selected folders to the panel where the local directory is
displayed, or you can even drag them to a Windows Explorer window or to the desktop.
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When you're done transferring data, just close FileZilla to disconnect from the data server and log out.

For more information on using FileZilla you can consult the program's help or the documentation
available on their website.

From:
https://sermn.uab.cat/wiki/ - SeRMN Wiki

Permanent link:
https://sermn.uab.cat/wiki/doku.php?id=howto_retrieve_your_data

Last update: 2024/02/07 15:01

http://wiki.filezilla-project.org/Documentation
https://sermn.uab.cat/wiki/
https://sermn.uab.cat/wiki/doku.php?id=howto_retrieve_your_data

	How to retrieve your data
	The folders on the data server
	Current spectrometers
	Former spectrometers

	Open the firewall of your institute or company
	Access your data with FileZilla
	Installation
	Detailed configuration
	Quick setup

	Example of data transfer session


